
Introduction 
  
  
In order to perform a numerical simulation, mesh and simulation conditions are essential.  All numerical simulation programs have 
programs called PreProcessors which create mesh and set the simulation conditions. The ideal PreProcessors can provide high-
quality graphics to check the shape inputted, create high precision mesh in a short amount of time and easily set simulation 
conditions.  
anyPRE can create mesh from shapes inputted through CAD files and carry out various CAD functions. Using anyPRE, you can set 

simulation conditions to run anySOLVER, which is AnyCasting's simulation engine.  
  
About anyPRE 
General Work Flow 
Input/Output Files 
About anyPRE    
        
        
Objectives 
anyPRE performs pre-processing by reading CAD data, forming FDM meshes and setting up simulation conditions to run 
anySOLVER. You can check the geometry of STL data by powerful graphic skill and make  millions of meshed within seconds. In 
addition, you can select the work processes and materials as well as boundary, heat, gate conditions, etc.. 
  
  
Characteristics 
anyPRE based on MS-Windows has been developed in a casting process-oriented way so that users working in the casting 
profession may operate the program with a little knowledge. 

General Work Flow 
     
     
anyPRE reads the geometry files as STL file or files created in anyPRE as GSC file. It  builds mesh and sets the simulation conditions 
necessary to run anySOLVER.  

1. Input of Geometry  Files as STL files 
  
  
2. Build Mesh 
  ① Set entity properties( See Set Entity ). ② Set mould( See Set Mould ). ③ Set simulation domain( See Set Domain ). ④ Build uniform mesh/variable mesh( See Build Uniform Mesh, Build Variable Mesh ). 
  
3. Set Simulation Condition   
Basic Procedure: Fields that must be set in order to execute the simulation   ① Decide upon the process and simulation method of the simulation( See Task Design ). ② Select material( See Material Setting). ③ Set initial temperature and plane boundary conditions( See Initial and Plane BC). ④ Set heat transfer conditions such as heat transfer coefficient and  coating effects of the interfaces of each entity( See Heat 

Transfer Model). ⑤ Set gate conditions( See Gate Condition ). ⑥ Set gravity force( See Gravity Force ).   
Optional Modules: Fields that may be optionally set depending on the simulation objective 
  
- Set fluid flow model(viscosity, turbulence, surface tension models)( See Fluid Flow Model). 
- Select solidification shrinkage model( See Shrinkage Model ). 
- Select microstructure model( See Microstructure Model ). 
- Select outlet( See Outlet ). 
- Set cyclic casting conditions( See Cyclic Casting ). 
- Set rotational force(See Rotational Force). 

User Interface 
    

Window users can easily operate the program as the menus and functions are 
Windows-based.  

Fast Meshing Algorithm 
  
    

Millions of grids can be created within a few seconds using the Surface Vector 
Tracking method. 
Efficient management of the number of mesh by variable mesh 

High Quality Viewing 
    

Inputted Geometries are analyzed by the view surface, view shape, measure and 
control transparency functions. 

Easy Setting of  
Simulation Condition    

The method of setting the simulation conditions is casting process-oriented, thus 
allowing even those who are not casting simulation specialists to run the program. 



  
Set Instruments: Fields that must be set if equipment exists   
- Install sensor to view temperature, velocity, pressure, etc. at a certain point( See Sensor ). 
- Set channel characteristics( See Channel ). 
- Set pouring basin conditions( See Pouring Basin ). 
- Set stopper conditions( See Stopper ). 
- Set feeder conditions( See Feeder ). 
  
  
4. Launching anySOLVER   
Launching Conditions   ① Set conditions necessary to launch anySOLVER( See Soluition Method). ② Set simulation end and save conditions( See End/Output Condition ). ③ Run anySOLVER after saving to a GSC file( See Run ). 
Input/Output Files     
In order to run anyPRE, STL files are necessary to input geometries. A GSC file is created which makes task possible again in 
anyPRE. In addition, a msh and prp files are saved which are needed to run anySOLVER.   

Input Files 
  

    

Output Files 
 
Select File/Save and you can save into a GSC file format.  While the GSC file is being saved, MSH and PRP files, which are 
necessary to run anySOLVER, are created.  The name of the msh and prp files are created the same as that of the gsc file.   

STL file 
    

The STL format is the same file format used in CAD programs.  Geometries are outputted in STL file 
format.  anyPRE reads these shape files and builds mesh. 

GSC file 
  
    

anyPRE creates the GSC file where you can save task information at any time and contains STL 
shape information as well.  This file is may be read to carry out new projects or continue previous 
ones. 

Project.gsc    File that contains the content that was used in anyPRE 
Project.msh    File that contains mesh information 
Project.prp    File that contains simulation conditions 



User Interface 
  
  
The user interface of anyPRE can be easily used by any Windows user. 
anyPRE is a user-friendly program that you can set up the conditions at a few clicks of the mouse and hit of the keypad. 
  
Window Layout 
How to Use the Mouse 
Manipulation of View 
Menu 
Toolbar 
Window Layout 
  
  
The anyPRE window can be largely divided into 5 parts as shown below.  Each window and tool bar can be arranged freely. 
  

 
  

How to Use the Mouse 
  
  
Basic Methods 
Rotate  Click on left mouse button and drag 
Move   Click on middle mouse button and drag OR press Ctrl + click on left mouse button and drag 
Zoom in/Zoom out   Use mouse wheel OR press Shift + click on left mouse button and drag 
  
  
View Fast Menu 
When the mouse cursor is on top of a specific entity, click on the right mouse button to see the menu of that specific entity. 
When the mouse cursor is on top of a background, click on the right mouse button to see the view menu. 
 
 

① Main Menubar The entire menu ② 
Various Toolbars 
  Composed of the standard, view, display, mesh, measurement, and cross-section toolbar. ③ Switch Window Window where main functions have been categorized into groups ④ Main Window Graphic window ⑤ Entity Window It is possible to view, at once, the name, color, size, volume, material, etc. of the entity. 



Switch to Select Mode 
When the function of setting gate condition, measuring and installing sensor is activated, press the space bar to turn on/off the select 
mode. Rotation is impossible during the select mode. 
  
  
Cross section 
When a plane of cross section is activated, move the mouse cursor to the four corners of the section plane and it will be changed into 
yellow. 
Hold onto the section plane with the left mouse button and move it to the preferred location. 
  
  
Mouse Cursor 
Below are the cursor shapes according to mouse mode 

  

See Also: Utilizing the Window 
Manipulation of View 
  
Basic Functions      

   Note 
Esc key enable you to return back to default mouse mode 
  
Save Current User View Point     
This can be used when creating a report or checking the design changes of two models. 
In order to save the current view point,  
    1. Select View -> View points -> Add User View(Alt+U) menu  
    2. Enter name of user in dialogue 
    3. A user defined view point is added as the last View Point field 
    4. If the added menu is selected, the saved view point is applied to the current screen 
  
Rotate around Screen Axis 
Select View -> Axial Rotate/Rotate Left/Rotate Right  menu 
It is possible to rotate at a 90 degree or selected angle based on the screen's normal vector direction. 
It is possible to easily obtain the wanted screen rotating along the screen axis after switching to the basic viewpoint(±x, ±y, ±z). 
  
Changing Projection Modes 
The projection mode of the current screen may be changed by selecting the View -> Perspective/Isometric menu. 
Perspective projection reflects perspective and isometric projection displays all in the same size regardless of the object's location.   

 
 

Basic mode, rotate 

 
 

Move 

 
 

Zoom in/Zoom out 

 
 

Rotate along screen axis 

 
 

Zoom in specific area 

 
 

Select mode 

 
 

Activate section plane 

 
 

Drag section plane 

Rotate    Click on left mouse button and drag 
Move    Click on middle mouse button and drag OR press Ctrl + left mouse button and drag 
Zoom in/Zoom out    Use mouse wheel OR press Shift + left mouse button and drag 
Zoom in/Zoom out 
Selected Area    

Select View ->Zoom Window OR Ctrl + left mouse button and drag and drop. 
Especially, press hotkey, C to zoom in selected area. 

Return to Previous View    Select View->Previous View OR press hotkey, V 
Return to Initial View    Select View->Reset View OR press hotkey, R  



  
  
View Cross-section 
It is possible to move the cross-section by entering the coordinates/indices in the cross section, using the spin button or the mouse.  
Using the mouse, you, 
    1. Select the Cross-Section->Active menu and turn on the cross-section. 
    2. When a cross-section plane is activated, move the mouse cursor to the four corners of the plane and it will be changed into 
yellow. 
    3. Hold onto the plane with the left mouse button and move it to the preferred location. 
         
It is possible to make a maximum of 3-direction(x, y, z) cross-sections.   

  
  
Set Background 
The background color and gradient can be selected in the File->Preference menu. 

Perspective Projection Orthographic Projection 

  
1. Cross-section Plane is ON 2. Move the mouse cursor on the plane edge and it 

changes the plane into yellow. 

  
3. Grab the plane by clicking the left mouse button. 4. Move the plane while holding down the left mouse 

button. 

 
Gradient Option ON Single Color Background 



  
  

See Also: How to Use the Mouse, Setting Preferences 
Menu    
        
File Menu 
New    Creates a blank document 
Open    Opens *.gsc files 
Close    Closes current document 
Save    Saves current document 
Save As    Saves current document in another name 
Import    Imports CAD files(*.stl) 
Export-Image    Saves current screen into BMP or JPEG file format 
Print    Prints current screen 
Print Preview    Provides preview of current screen to be printed 
Preference Sets environment including background color, database unit  
Description    Inputs and edits description of current document 
Exit    Closes all open documents and terminates program 
 
Edit Menu 
Copy to Clipboard    Copies current screen to clipboard 
Merge Entity Merges selected entities 
Reset Transformation    Resets entity transformations including move, rotate, etc. 
 
Mesh Menu 
Set Entity    Sets properties of each entity 
Set Mould    Sets size and type of mould 
Set Domain    Sets domain size and symmetrical planes 
Build Uniform Mesh    Builds uniform mesh 
Build Variable Mesh    Builds variable mesh 
Undo Meshing    Deletes built mesh, any simulation conditions set previously are not maintained 
 
Simulation Menu 
Basic Procedure : Basic simulation conditions    
Task Design    Sets casting process and analysis type 
Material Setting    Sets and changes properties of each entity from database 
Initial and Plane BC    Sets initial conditions of each entity and boundary conditions of six planes 
Heat Transfer Model    Sets heat transfer coefficient and coating conditions between entities 
Gate Condition    Selects gate and sets thermal and flow conditions 
Gravity Force Sets gravity force 

Optional Modules :     
Fluid Flow Model    Sets viscosity/turbulence/surface tension models 
Shrinkage Model    Sets solidification shrinkage defect prediction model 
Microstructure Model    Sets microstructure prediction model 
Outlet   Sets conditions when the melt flows out the domain 
Cyclic Casting    Sets cyclic casting conditions 
Rotational Force Sets rotational force 

Set Instruments : Sets various instruments 
Sensor    Install and set sensor 
Channel 
  

Sets cooling or heating channel conditions (Activated when a CHANNEL ENTITY is 
defined) 

Pouring Basin 
    

Sets pouring basin conditions (Activated when a POURING BASIN ENTITY is 
defined) 

Stopper    Sets stopper (Activated when a STOPPER ENTITY is defined) 
Feeder    Sets feeder (Activated when a FEEDER ENTITY is defined) 
 
Launching Conditions : Sets anySOLVER launching conditions 
Solution Method    Sets solution method of heat and flow solver 
End/Output Condition   Sets end condition and output conditions of result file 
Run    Launches anySOLVER 

 



Toolbar 
  
  
Standard Toolbar 
 

Cross-Section Menu 
Active    Activates cross section plane 
Cross-Section YZ    Sets current plane to cross-section YZ(x-axis direction) 
Cross-Section XZ    sets current plane to cross-section XZ(y-axis direction) 
Cross-Section XY    sets current plane to cross-section XY(z-axis direction) 
Flip    Flips currently visible area around plane 
Section Plane    Shows/hides section plane 
Section Grid    Shows/hides section grid 
Reset    Resets plane to initial mode 
 
Measure Menu 
Vertex Coordinate    Indicates coordinates of one vertex 
Distance between 2 Vertices Indicates distance between 2 vertices 
3 Vertices Angle    Indicates angle between 2 straight lines composed of 3 vertices 
3 Vertices Radius    Indicates radius of circle composed of 3 vertices 
Surface Area 
    Calculates total surface area of all entities except automatic build mold 

Volume    Calculates total volume of all entities except automatic build mold 
 
View Menu 
Perspective    Switches current screen to perspective projection (perspective) 
Isometric    Switches current screen to isometric projection (no perspective) 
View Point    Sets view point of viewer (switches to perspective projection) 
Add User View    Adds view point defined by user 
Rotate Left    Rotates current screen 90 degrees to the left based on screen's normal vector 
Rotate Right    Rotates current screen 90 degrees to the right based on screen's normal vector 
Axial Rotate    Rotates current screen at a specific angle based on screen's normal vector 
View Mode      
   Geometry  Shows entities as geometries inputted 
    Mesh Shows entities as mesh 
    Mesh Line Shows mesh line 
Zoom Window    Zooms in selected area 
Fit to Window    Zooms in or Zooms out fit current screen size 
Previous View    Returns to previous view 
Reset View    Returns to initial view  
Spinning    Rotate all entities at a selected speed and direction 
Fast Moving  Turns on/off function to swiftly display current screen  
 
Display Menu 
Axis    Shows/hides axis on lower right area of screen 
Auxiliary Axis    Shows/hides auxiliary axis in center of screen 
World Axis Shows/hides world axis which is located at 0,0,0 
Vertex    Shows/hides vertex existing in space 
Entity Extent    Indicates entity extent  
Mold Extent    Indicates mold extent 
Domain Extent    Indicates domain extent 
Logo    Shows/hides AnyCasting logo 
 
Window Menu 
New Window    Creates new window 
Cascade    Cascades all windows currently open 
Tile Horizontal Arrange windows as non-overlapping tiles horizontally 
Tile Vertical Arrange windows as non-overlapping tiles vertically 
Arrange Icons    Arranges all icons 
 
Help Menu 
Contents    Shows online help contents 
About    Shows version information and various contact numbers 
License    Certification/disuse of license 



 
  

  
 
Measure Toolbar 
 

 
  

  
 
View Toolbar 
 

 
  

  
 
Display Toolbar 
 

 
  

 New Creates new document 

 Open Opens document 

 Save Saves current document 

 Save All  Saves all documents 

 Print  Prints document 

 Print Preview Previews print document 

 Import Imports CAD file 

 Export Exports current screen as image file 

 Copy to Clipboard  Copies current screen to clipboard 

 Shows/hides module window   

 Shows/hides entity window   

 About About anyPRE 

 Vertex Coordinate Finds the coordinates of a vertex 

 Distance between 2 Vertices Finds the distance between 2 vertices 
Center of Segment Finds the angle made by 2 lines composed of 3 vertices 

 3 Vertices Angle Finds the angle made by 2 straight lines composed of 3 vertices 

 3 Vertices Radius  Finds radius of circle composed of 3 vertices 

 Zoom Window  Zooms selected area 

 Fit to Window Zooms in or Zoom out to current screen size 

 Previous View Returns to previous view 

 Reset View Returns to initial view 

 Spinning  Rotates all entities at a specific velocity and direction on screen  

 Axial Rotate Rotates current screen at a specific angle based on screen's normal vector 

 Rotate Right Rotates current screen 90 degrees to the left based on screen's normal vector 

 Rotate Left Rotates current screen 90 degrees to the right based on screen's normal vector 

 View Point Sets view point of viewer 

 Projection Mode Switches to projection mode 

 Geometry Mode Switches entity to view inputted geometries 

 Mesh Mode Switches entity to view mesh 

 Fast Moving Turns on/off function to swiftly display current screen 

 Entity Extent  Shows entity extent 

 Mold Extent Shows mold extent 

 Domain Extent Shows domain extent 

 Vertex Shows/hides vertex existing in space 

 Axis Shows/hides axis in lower right area of screen 



  
 
Mesh Toolbar 
 

 
  

  
 
Cross Section Toolbar 
 

 
  

 Auxiliary Axis Shows/hides auxiliary axis in center of screen 

 Merge Entity Merges selected entities 

 Set Entity Sets properties of each entity 

 Set Mold Sets size and type of mold 

 Set Domain Sets size and symmetrical plane of domain 

 Build Uniform Mesh Builds uniform mesh 

 Build Variable Mesh  Builds variable mesh 

 Undo Meshing Deletes built mesh 

 Active Activates view plane function 

 Cross-Section YZ Sets current plane to cross-section YZ(x-axis direction) 

 Cross-Section XZ Sets current plane to cross-section YZ(y-axis direction) 

 Cross-Section XY Sets current plane to cross-section XY(z-axis direction) 

 Section Plane Shows/hides section plane 

 Section Grid Shows/hides section grid 

 Flip Flips currently visible area around plane 

 Reset Resets plane to initial state 

  ① Coordinates of current plane 

  ② Number of meshes of current plane 

  ③ Number of meshes in currently selected direction 



Entities 
 
An entity is the smallest unit composing the casting system in anyPRE. It is created by reading CAD files. In case of box or cell mold, 
it is generated automatically. 
 
Entity Introduction 
Moving and Rotating Entities 
Merging/Smashing Entities 
Measurement 
  
Entity Introduction 
  
  
Entity Properties 
In order to build mesh or input simulation conditions, it is necessary to give properties to all entities. 
 
CAST    The domain which melt fills up 
MOLD    mold 
INSERTED    Material inserted into the cast such as core 
ATTACHED    Materials attached to the cast or mold such as chill 
CHANNEL   cooling or heating channels     
Viewing Entities 
 
The rendering mode of each entity is as follows.  You can change the render mode by the following two way. 
1. Move the moue on top of entity and click on the right mouse button. Select the Render Mode. 
2. Click on the Set Entity field. In Set Entity, change the Mode in Display field.   

  
  
Using the Right Mouse Button Menu 
 
When the mouse cursor is on top of an entity, the menu of that specific entity is displayed.  The functions of each menu is as follows. 

CAVITY    Cavity 
   INGATE    Ingate 
   OVERFLOW    Overflow 
   POURING_BASIN    Pouring Basin 
   STOPPER    Stopper 
   FEEDER    Part which feeds the melt in low pressure casting 
   GATE    Gate located inside of a mold (Inner-Gate)

Geometry Viewing 

   
Solid Line+Solid Line 

 
Mesh Viewing       

Solid Line+Solid Line Mesh Line 

 ① Name and properties of entity 



Moving and Rotating Entities 

  

Place mouse cursor on top of entity that needs to be moved/rotate and click on right mouse button.  Then, select Transform in entity 
menu.  

  

Move 

Relative     Move the currently selected entity in the x, y, z directions by the relative displacement 

  

 

  

Vector      Move the current entity by the distance between the two vertices selected with the mouse 

   Note 

Esc key enable you to cancel and return back to default(rotate) mouse mode 

  

Rotate 

Rotate the currently selected entity with the origin of the rotational axis. 

  

 

 

 ② Select render mode among solid, line + solid, or line 

 ③ Change color 

 ④ Control transparency 

 ⑤ Hide entity (show: Have 'visible' field checked in the entity window) 

 ⑥ Volume, surface area, modulus, number of triangles, number of cells 

 ⑦ Move/rotate current entity 

 ⑧ Replace entity's geometry keeping its attribute 

 ⑨ Smash merged entity

 ⑩ Delete entity



  

Axis       Select rotational axis 

Origin    Input pivot point 

Angle     Input rotational angle 

  

Undo Changes 

to undo transformation :  

1. Place mouse cursor on top of entity of which the changes need to be undone.   

2. Click on the right mouse button to load the fast menu, then select Transform -> Reset.  

Merging/Smashing Entities 

  

Merge 

Merge two or more entities into an entity with one property. 

Select the entities to be merged by checking the box and click the 'Merge' button. 

  

 

  

Select all       Selects all entities 

  

Smash (Undo Merge) 

if you want to "undo merge", use "smash" of the merged entity's right-mouse button menu. 

See Also : Entity Introduction 

  

Measurement 

  

Switch the mouse to the select mode by hitting the space key and select the white vertex.  A measuring value will be displayed in the 
measuring output window. 

  



Value measured by Vertex 

1. Select one of the below fields in the Toolbar of Measure Menu. 

  

2. Press the space bar and switch from mouse mode to select mode. 

3. Click on the indicated vertex and the measurement will be displayed as follows: 

  

 

  

  

Value measured by Entity 

1. Move the mouse on top of entity that needs to be measured. 
2. Click on the right mouse button and select Volume, Surface Area, Modulus in property fields of the fast menu. 

  

  

Value of total Entity 

1. Select the Measure Menu 

    Volume        Total volume of all entities except castings that have been created automatically 

    Surface Area  Total surface area of all entities except castings that have been created automatically 

2. Values of each entity are displayed in the volume and surface area fields in the lower entity window 

  

See Also  How to Use the Mouse 

Vertex Coordinate Show coordinates of one selected vertex 
Distance between 2 Vertices Show distance between two selected vertices 
Center of Segment Show center point of a segment 
3 Vertices Angle Show angle formed by 3 selected vertices 
3 Vertices Radius Show radius of circle composed of three selected vertices 



Mesh Generation 
  
  
A hexahedron of a certain size, a mesh is the smallest unit that composes the simulation domain. 
As it has the largest effect on the reliability of the simulation results, you must fully understand. 
After a mesh has been built, it must always be checked by cross section and other observation function. 
As the quality of the mesh depends on the ability of the user, you must read, learn and practice repeatedly. 
  
Setting Entity Properties 
Setting the Mould 
Setting the Domain and Symmetrical Planes 
Building a Uniform Mesh 
Building a Variable Mesh 
Setting Entity Properties 
  
  
Double-click the entity or select Mesh -> Set Entity from the menu. 
The properties, color, names of the entities in the system will be shown. 
Select the properties of each entity in combo box of Type field. 
  

     
  

                   

See also : Entity Introduction 
Setting the Mould 
  

 Name    Entity name 
Type    Select entity property. Auxiliary properties can be set in case of a cast. 
Display    Change the display properties of the current entity.  
    Visible Show/hide 
    Mode Select rendering properties 
   Color  Select color 
   Opacity  Set opacity 



       

Make CAST from the Cavity of Mould 
Check it if you want to make CAST from the mould cavity (inverse meshing), and imported mould geometry must be a 
box shape.    Note 
In case of cyclic casting, there has to exist two or more mold entities. "Mould Entity" must be choosen.   
Gate Plane 
Select the plane where the gate exists and the wall thickness automatically becomes '0'.   
See Also: Setting Cyclic Casting 
Setting the Domain and Symmetrical Planes 

  

  

Of the entire domain, create the new domain by selecting a interested area by inputting the coordinates or the ratio for each wall. 
If the geometry is symmetrical, half of domain can be solved. 

  

Domain 
Casting Only    choose when there is only a casting 
Casting+Mould    choose when there is a casting and a mold 
  
Mould Type and Dimension 
Box 
    

Making a rectangular mold  
You can enter the wall thickness of each direction 

Shell 
  

Making a shell mold  
You can enter the shell thickness 

Mould Entity    Select mold made by reading the geometry from a CAD file 
Possible to select only when the entity properties have been set as 
mould 



     

  

  

Information 

Displays the size of the entity and mold. 

  

  

Domain and Symmetry 

  

Building a Uniform Mesh 
  
Divide the selected domain into meshes of a certain size.  Enter the values in each field and click on 'Apply' or hit the 'Enter' key and 
the optimized mesh size will be displayed. 
  

     
  

 Note 
When the cast entity becomes divided two or more isolated parts during building a mesh, a warning message pops up and each area 
is displayed in different colors. 
  

Coordinate    Coordinates of each boundary plane 
Ratio    The ratio of the size of the entire area to the location of the current boundary plane 
Symm.    Of the 6 planes, select the symmetrical planes by checking the boxes 



  
Domain Size 
Show domain size 

Building a Variable Mesh 

  

It is possible to focus meshes in a certain area of the domain and decrease the number of meshes by applying an auto-block. It raises 
the accuracy and reduces the calculation time of the simulation. 

 

     

   

Types of Blocks 

  

  

  

Dialog 

  

Meshing Scheme      
Total Number of Cell    Sets the total number of cells in the domain 

  Move the slide bar on the right up and down or enter the value directly 
into the field 

Number of Cell Along Axis    Sets number of cells along each axis 
Size of Unit Cell    Sets size of unit cell for cube 
Size of Cell    Sets size of cell along x,y,z directions 

User Block   

  

Block that has been built as a result of user-defined block setting the Start and End 
points. Displays in blue. 

Auto-Block 

  

Block that has been automatically built by clicking on the Auto button. 

Displays in gray 



     

  

  

  

  

Build Block 

  

User Block 

1. Select the axis. 

2. Press the space bar and switch from mouse mode to select mode. 

3. Of the white vertices, select two vertices. The smaller is the starting point and the bigger is the end point. 

4. After setting the division number, press the 'Set' button or 'Enter' key. (the newly build block will be displayed on screen) 

  

Auto-Block 

Axis    Select the current axis of direction 
Block Setting 
     Start    Start point of the block 
     End    End point of the block 
     DivNumber    Number of divisions of the block 
Set    Set the block according to the start point, end point and division number 
Remove   Current Block : remove currently selected block 

 All Blocks : remove all blocks 

 Auto-Block : remove only automatically created blocks 

Show Grid    Show/hide the grids of the block 
Smooth Factor    Increase ratio of neighboring cell sizes 
Max. Size Ratio    Ratio of Maximum mesh size to the smallest mesh in auto block 
OK    Build mesh when blocks settings are complete 
Cancel    Maintain current block settings and exit without building mesh 



After completing setting the user block, click on the 'Auto' button and a block will be automatically created for the empty area.   

Build Mesh 

1. Create a user block. 

2. Create an auto-block. 

3. Repeat steps 1 and 2 for each axis and then click on the 'OK' button to build mesh. 

   Note 

Should a block with red marks be created, it means that mesh couldn't be built automatically. In that case, you must modify the 
following values. ① User sets the division number ② Change Factor and Ratio ③ Change division number of blocks at each end 

After modifying these values, you build the mesh again. 

   Note 

When the cast entity becomes divided two or more isolated parts after building a mesh, a warning message pops up and each area is 
displayed in different colors. 

  

Change Block 

Change the values for the Start, End, and DivNum fields, then click on the Set button. 

  

Remove Block 

  

Remove current block  Click on 'Remove' button then select Current-Block 
Remove Auto-block    Click on the 'Remove' button then select Auto-Block 
Remove all blocks    Click on the 'Remove' button then select All Blocks 



Setting Simulation Conditions 
  
  
There are 4 basic categories to set for simulation conditions. 
  
Basic Procedure  
 
Task Design 
Select Material 
Initial Conditions and Plane Boundary Conditions 
Heat Transfer Model 
Setting the Gate 
Setting Gravity Force 
  
  
Optional Module  
 
Setting Flow Models (Viscosity, turbulence, surface tension) 
Solidification Shrinkage Prediction Model 
Setting Cyclic Casting 
Setting Outlets 
Setting Rotational Force 
   
Set Instruments 
  
Setting Sensors 
Setting Cooling Channels 
Setting Pouring Basins 
Setting Stoppers 
Setting Feeders 
   
Launching Condition  
 
Setting Simulation Method 
Simulation End and Result Output Conditions 
Launching anySOLVER 
  
  
Task Design 
     
     
Target Process 
Select the casting system to be simulated in the 4 groups listed below. 

         

� Group 1 (Non-Metal Mould) 

- Sand Casting 
- Investment Casting  

� Group 2 ( Metal-Mould) 

- Metal-Mould Casting 
- Gravity Tilt Pour Casting  

� Group 3 (Pressurized) 

- High Pressure Die Casting 
- Low Pressure Die Casting 
- Vacuum Die Casting 
- Squeeze Casting 



- Thixo-Forming Process  
� Group 4 (Special) 

- Centrifugal Casting 

- Electro Slug Melting Process  

        
Analysis Type    
        

            

� Mould Filling ( No Heat ) Select when only carrying out a filling simulation  
� Heat/Solidification Select when only carrying out a heat/solidification simulation  
� Mould Filling and Heat ““““During Filling”””” Select when only carrying out a filling and heat simulation during filling  
� Mould Filling and Heat / Solidification ““““During and After Filling”””” In this type, a filling and heat/solidification simulation is 

carried out during filling. After filling, only heat and solidification simulation is performed  
� Include Transient Period In this type, a filling and heat/solidification simulation is carried out during and after filling.  

Note  The Include Transient Period option is selected when the flow patterns of the mushy zone plays an important effect on 
solidification after filling. Thus, the result of this option may be better than those of above other options. But it takes a lot of simulation 

time. We recommend using the Mould Filling and Heat / Solidification ““““During and After Filling”””” option.  
Selecting Materials 
     
     
Set the material of a selected entity in the database.   

              
Selecting and Changing an Entity Material 

1. Select the entity in the list. Multiple selections are possible using ctrl or shift + left mouse button.  
2. Click on the Database button or double click the selected entities.  
3. Select the material in the Material Selection box.  
4. Double-click on the material or click on the 'OK' button with selecting material. The selected entity will be set. 

- The properties of air are set automatically.  



Changing the Properties of the Material 

1. 11 properties appear in the Material Information list.  
2. Double click on each property and a View / Edit window will appears as below.  
3. Click on the 'OK' button and complete the change. (the 'OK' button activates only when the materials of each entity have all 

been set.)    

Using User Defined Material Information 

1. Load the preferences window in the File-Preference menu.  
2. Click on   in the User Database menu and select the *.mdb file created in anyDBASE.  

3. Select User Database in the list .  

Note  Material information is not saved in case the Undo Meshing function is executed 

Initial Conditions and Plane Boundary Conditions 
     
 
Initial Conditions 
Set the initial thermal conditions of each entity. 
If it is an entity with cast properties, assume that it is filled with air as it is empty before filling. 
On the contrary, if only carrying out a heat/solidification simulation(select Heat/Solidification field in Analysis Type), enter the 
pouring temperature of melt as it has already been filled.  
If preheating the mould, enter the preheating temperature. 
  

     
                  
Plane Boundary Conditions 
Set the thermal conditions of each plane(±x, ±y, ±z). 
  

     
  
Item (Thermal conditions) 

Item ( Thermal Condition )      

     Temperature    Enter initial temperature. Default value  is  25℃. 

Normal    Heat transfer including convection and conduction 
Adiabatic    Adiabatic plane 



  
  

See Also  Inputting Variable Data, Task Design 
Setting Heat Transfer Model 
  
  
This function automatically finds and displays the interfaces between each entity. Multiple selection of the interfaces are possible. 
  
Setting the Heat Transfer Coefficient 
The coefficient can be imported from the heat transfer coefficient database of each interface or you can set it up. 
 

       
    
Setting Coating Layer 
Define the heat transfer and coating thickness of the materials to be coated on the various interfaces or one interface. 
Double-click on the interfaces in the list or click on the Database button with selecting the interface. And then select the materials 
from the 'Coating' group. 
 

Constant Temp.    Constant temperature 
Variable Temp.    Time dependent temperature 
Constant Flux    Constant heat flux 
Variable Flux    Time dependent heat flux 

Heat Transfer Coefficient 
    Database Automatically sets the HTC according to the two adjacent materials  

    Select from gravity and low/high pressure depending on the process 
    User defined Defined by user 



           
Setting the Gate 
  
  
Gate conditions can be largely categorized into two levels: during filling and after filling. 
It is possible to use the mouse to add/delete on the screen.  The program supports multiple gates and enables setting of direct-
pouring and modules for the optimized simulation of die casting processes. 
  
Adding/Deleting Gates 
1. Select Set Gate from the menu and gate area is displayed in red on the window. 
2. Press the space bar and switch from mouse mode to select mode. 
3. Select the area in red using the mouse and add it to the list. 
4. If you delete the current gate in yellow, select it again. 
  
  
Setting Gate Heat/Flow Conditions   

Coating Material Name of coating material 
Thermal 
Conductivity    Thermal conductivity of coating material 

Coating 
Thickness    Coating thickness of coating material 



           
Name  
Set the gate name. The default value is "Gate_number".   

See Also   Inputting Variable Data 
Setting Gravity Force 
  
The gravity force  is set. 
 

During Filling (before cavity is filled up completely) 
Thermal Condition Set the thermal conditions of the melt 
Flow Condition Set the flow conditions among velocity, pressure and height 
 
After Filling (after melt filling is completed) 

Thermal Condition Set thermal conditions of the gate plane exposed to 
the outside 

  Normal  Heat transfer conditions including convention, conduction, and radiation 

  Adiabatic    Adiabatic condition 

  Constant Temp.    Constant temperature 

  Var Temp.    Time dependent temperature 

  Constant Flux    Constant heat flux 

  Var. Flux    Time dependent heat flux 

 
Option   

HPDC    Velocity condition optimized in high pressure die casting(HPDC) 
Direct Pouring    Gravity Casting using the Lip Pouring Ladle 
Filling Time     Indicates estimated filling time when the velocity is constant. 



         
  

Viscosity Model 
  
  
This is where the viscosity for a non-Newtonian flow is set. 
 

     
  

  

Note     
The 5 viscosity models excluding the Newtonian flow are as follows: 
  

Enable Gravity Force Turns on/off gravity force 
Direction Select direction or input vector 
Magnitude Input magnitude of gravity force 

Material   Indicates material of entity set as cast 
Model   Select viscosity model 
    Newtonian Select in most metal castings, default value 
    Effective Viscosity   

    Bingham   

    PowerLaw   

    Carreau   

  Ellis   

Viscosity      

  Database Use viscosity value imported from the database 

  User define Input user defined viscosity value 

Effective Viscosity Curve Model  
The change in viscosity for a solidification fraction have been modeled as a function 
  

 
 

: viscosity value  

: model consonant 

 
 



Turbulence Model 
    
This is where the turbulence model  is set.   

       
    
Note  
There are various types of formulas used in turbulence models.  For the Standard k-ε model, the most standard model of turbulence 
models, there are two differential equations and one equation on turbulent viscosity.  

Bingham Viscosity Model 
  

 

 ,   (Shear rate)

 

 

: viscosity value  

: yield stress of material 

 
 
Carreau Viscosity Model  
  

, 

 

 viscosity value 

 viscosity value  
 when shear rate reaches infinity 

 model constant 

 
 
Ellis Viscosity Model  
  

,       

 

 viscosity value 

 
 for 

 

 model constant 

 
 
Powerlaw Viscosity Model  
  

,      

 : viscosity value  

: model consonant 

On    Turn on/off turbulence model 
Model   Select turbulence model 
   Standard k-ε model  
   RNG k-ε model  

Wilcox k-ω model    
Constants   Constants used in a turbulence model 



                                  

             
The consonant values are as follows:    
Surface Tension Model 
  
  
This is where the coefficient of surface tension and the wall adhesion angle are set. 
  

       

  
  

Note  
Surface tension can be expressed as follows: 
 

                              : Coefficient of Surface Tension, : K : Curvature 

  
The surface tension induces the wall adhesion. By setting the wall adhesion angle at the point where the melt contacts with the wall, it 
is possible to reflect the wall adhesion effect in the simulation.  The wall adhesion angle is the angle indicated below. 
  

  Standard k-ε RNG k-ε Wilcox k-ω 

 0.09 0.085 0.09 

 1.44 1.42 0.56 

 1.92 1.68 0.075 

 1.00 0.7179 2.00 

 1.30 0.7179 2.00 

On    Turn on/off surface tension model 
Model    Standard CSF Model 
Surface 
Tension    Select method to enter surface tension 

    Database Use value imported from database 

  User defined    Input user defined value 

Wall Adhesion  
Model    

Set whether or not wall adhesion force will be simulated 
Enter angle in activated input field 



 
  
Definition of Wall Adhesion Angle 
Solidification Shrinkage Model 
  
This model is used to predict solidification shrinkage. 
 

     
  

Microstructure Prediction Model 
  
The deterministic model and parametric model are models used to predict microstructure. 
  
Deterministic Model 
The size of a grain or density of spheroidal graphite nodules can be found using this model. 
 

On    Turn on/off shrinkage model 
Material    Material of casting 

  
 
Volume Change of Solidification Shrinkage    

DataBase Use value inputted from database 
User defined Input user defined value 

  
 
Critical Solidification Fraction    
Critical solidification fraction is categorized as follows: 
Parametric Model 
  

Solid fraction that records the basic parameters necessary in predicting 
shrinkage 

Gravity Shrinkage Percentage that gravity shrinkage takes up of the entire shrinkage 

  DataBase Use value inputted from database 

  User defined Input user defined value 



     
  

   Note 
The above model is based on the nucleation and growth kinematics.  
Thus, if the data on both kinetics are valid, it is possible to obtain reliable results. You must carefully enter and select the data. 
  
Parametric Model 
It is possible obtain information on various types of microstructure using this model.  Solute diffusion, heat diffusion, and length of the 
capillary tube are obtained and used as the basic parameters to predict the microstructure. 
 

     
  

  
Parameters 

On Turn on/off deterministic model 
Model Select deterministic model 
Alloy System Select alloy system 

  Al-Cu Al - 4.5wt%Cu alloy standard 

  Al-Si Al - 7wt%Si alloy standard 

  Ductile Cast Iron Spheroidal graphite iron 

  Magnesium Alloy  AZ901D standard 

  User defined Use new values other than those provided above 

NucleationKinetics Enter data on nucleation kinetics 
Growth Kinetics Enter data on growth kinetics 

On    Turns on/off parametric model 
Model    Select parametric model 
Alloy System    Select alloy system 
   Al-Cu    4.5wt%Cu basis 
   Al-Si    7wt%Si basis 
   Ductile Cast Iron    Ductile Cast Iron basis 
   Magnesium Alloy    AZ901D basis 
   User Define    Use new value other than those provided above  



Setting Outlet 
  
Like a vent or a exit, an outlet is the area where the melt flows to the outside.   
Select/Delete Outlet 
1. Open the Outlet window. 
2. The areas that may be selected are indicated in brown. 
3. Press the space bar and switch from mouse mode to select mode. 
4. Click on the brown area. (That will be selected and added to the list.) 
5. If you delete the current outflow in yellow, select it again.     
Setting the Outlet   
       
Setting Cyclic Casting 
  
This is where the general conditions for cyclic casting are set.   

       
Setting Cycle   
Add a Cycle Click Add Button, default analysis type is "Heat/Solidification only".  
Delete a Cycle Click Delete or Delete All button. 
Modify Analysis Type of Each Cycle Double click an item, or click Properties button then it shows dialog.    Note 
It is very general that set "Heat/Solidification + Fluid Flow" for the last cycle only.   
Setting Events 
Every Event must have a happen time and/or duration. You can Add/Delete an event using Add/Delete button.  
Click Add Default button to add default events (Die-Open, Die-Open, Spraying, Die-Close, Lead Time). 
Cycle Time is automatically calculated and shown at the bottom part of above dialog.   
for more detail, click followings 
Event in Cyclic Casting 
Event Diagram 

Gibbs-Thomson Coefficient    Super-cooling coefficient resulting from capillary tube effects 
Initial Solute Concentration    Initial solute concentration 
Solute Diffusivity in Liquid    Solute diffusivity in liquid 
Liquid Slope     Liquid slope 
Partition Coefficient     Partition coefficient 
Interatomic Distance    Interatomic distance 

No    Number of outlets 
Name    Name of each outlets(default value - outlet #) 
Dir.    Plane directions 
Area    Cross-sectional area of each outlets 



  
Setting Rotational Force 
  
 
The rotational force is set in this section. 
 

             
  

  
  

See Also  Inputting Variable DAta 
Setting Sensors     
Using sensors, you can check velocity, pressure and temperature at specific positions. In this section, learn how to embedded in the 
interested positions. 
Click on the Simulation -> Set Instruments -> Sensor menu. The cross-section plane will be activated and the sensor input window 
will load.   

           

On Turn on/off rotational force 
Rotation 
Axis    Select rotation axis 

Axis Origin Axis origin 
Axis Vector Axis vector 

   ex) Rotation around ±x axis ±1,0,0 
        Rotation around ±y axis 0,±1,0 
        Rotation around ±z axis 0,0,±1 
Rotation Angle Select rotation angle  

Start Angle Angle where rotation starts 
End Angle Angle where rotation ends 

Rotation 
Speed Set rotation speed(R.P.M) 

Constant Constant rotation speed 

 Variable 
Click on button  



  
Adding a Sensor 
 
Adding a Sensor Using the Mouse 
1. Move the activated section to the area of interest. 
2. Press the space bar to switch from mouse mode to select mode. 
3. Click on the point of interest and it will be added to the list 
4. In field ①, it is possible to check the sensor name, coordinates and entity under which the sensor is located. 
 
Adding a Sensor Using Coordinates 
Click on the 'New' button. In the following dialogue, enter the name(default value: Sensor_#) and coordinates of sensor to be added. 
The available range of the coordinates will appear in ②. 
 

               
  
  
Change Position of a Sensor 
Click on the 'Modify' button and modify the name and position of the current sensor. 
The available range of the coordinates will appear in ③. 
 

               
  
  
Removing a Sensor 
Click on the 'Remove' button and the current sensor will be removed. 
Setting Cooling/Heating Channels 
  
The operation conditions of cooling/heating channels are set in this section. 
CHANNEL type entities are shown in the list. 
  



     
     
1. Turn on/off by clicking Check button on the 1st column of each entity. 
2. Select Channel Model. (Constant HTC Model, Constant Flux Model) 
3. Set other conditions  
4. Check "Clone CHANNEL conditions for the cyclic casting" button if you want to adjust time-dependent channel conditions 
automatically. 
  
For more detail, click below.  
Setting Conditions 
Clone Channel Conditions 
   Note 
If you turned off the channel, it could not be activated even you input all conditions. 
it treated as a cavity filled with air. 
  
The heat transfer model of a channel is categorized into the Constant HTC and Constant Flux models. 
  
Constant HTC Model 
In this model, heat transfer coefficient, h is found by correlation equation with inlet/outlet temperature, inflow flux, cross-section shape 
of channel. With the found HTC value between adjacent entities, heat transfer is calculated. 
The strong point of this model is that the flux towards the channel changes according to the temperature of the entity that lies 
adjacent to the channel.  On the other hand, its weak point is that it fails to hold a generality because it uses the experimental 
correlation equation. 
  
Constant Flux Model 
In this model, total heat flux from the channels to neighbor entities is found from the channel's inlet/outlet temperature.  
Unlike the HTC Based Model, this model does not use the experimental correlation equation.  This means that it may be applied 
generally regardless of the shape of channel. However, there exists the weak point that the heat flux between channel and neighbor 
entities is calculated constantly. 
Setting Pouring Basins 
  
  
This is where the working conditions of a pouring basin are set. 
  

             
  



  

  
 Note 

Melt-Temperature is set as initial temperature of the POURING_BASIN type entity if  you 'Feeding Continuously' or 'Feeding Once'. if 
you choose 'Feeding from a Ladle', the temperature is correspond to the pouring temperature of the gate. 
  
Pressure 
To force the melt to enter into the cavity, the empty volume of pouring basin is filled by pressurized air. In this field, set the pressure 
value.   
  

See Also  Types of Input Values, Inputting Variable Data 
Setting Stoppers 
  
  
This is where the working conditions of the entity set as a stopper are set. 
  

          
  
Settings 
Set the conditions when the stopper opens. 
  

  
When the volume fraction function is set, click on the 'Select Entity' button and the cast-type entity will appear in the window below. 
Choose one or more entities to be used as objects in volume fraction 
 

          

Entity    
Name    Indicate name of entity set as pouring basin 
Material    Material of pouring basin  

Melt Feeding  

Melt-Amount

This has two meaning 
1. Volume of melt fed into the pouring basin initially for feeding continuously or 
feeding once option. 
2. Volume of melt at that the feeding is stopped for Feeding From Ladle option  

Melt Temperature Temperature of the molten alloy

How to Feed  

 Feeding Continuously 
(Constant Level)    

The volume of the melt in the pouring basin is maintained at a constant level 

 Feeding Once 
    

The pouring basin is fed once at the beginning with a certain amount of melt, then no 
longer feeding. The amount of melt in the pouring basin changes. 

 Feeding From Ladle 
    

Feeding the pouring basin from the ladle 
The gate condition must be set on the gate plane. 

Holding Time    The stopper opens when the time set by the user expires. 
Volume Fraction    
  

The stopper opens when a specific entity is filled with more than a 
certain amount of melt 



Setting Feeders 
  
This is where the working conditions of the entity set as the feeder are set. 
  

         
  

   Note 
When the solid fraction of one mesh is below the input value, it is considered as liquid.   
The melt is removed at feeder-out time and filled with air of a constant temperature. 
Setting Simulation Method 
  
anySOLVER is composed of a solver that simulates the mould filling of the melt and a solver that simulates the heat and solidification 
of the melt.  The organic combination of both solvers enables simulation of the entire process from melt filling to solidification. 
  
Mould Filling 
This is where the condition factors of the solver simulating the melt flow are set. 
  

         
  

Feeder-Out Time    Time when melt inside feeder is removed 
Solid Fraction    Standard solidification when melt inside feeder is removed 
Air Temperature    Temperature of air to be filled inside feeder after melt has been removed 

Solution Target    Indicates the target to be simulated by the solver 
Solver Type    Indicates solver type (Hybrid Only) 
Iteration Target    Variable that is solved by iteration method  
Iteration Method    Select iteration method among Jacobi (default value), SOR 
Relaxation Factor    Relaxation factor to be used during iteration simulation 
    Jacobi (0 < Relaxation Factor < 1), default value =0.8 
   SOR (1< Relaxation Factor < 2), default value =1.2 
Convergence Criterion    Convergence criterion ofiteration method ( <0.001, default value=0.001) 
Maximum Iteration    Maximum number of iterations ( >50, default value =100 ) 
Convection Scheme    Treatment of convective term of Navier-Stokes Equation 

  Central 

  Fully Upwind (default value)    



  
  
Heat / Solidification 
The heat solver simulates the temperature and solidification. This is where the condition factors for the heat solver are set.  
  

          
  

  
  NoteNoteNoteNote    
The following 3 equations need to be analyzed in casting simulation. 
Navier-Stokes Equation or Momentum Equation 
Continuity Equation 
Volume of Fluid Equation   
Iteration Method 
For simulation of incompressible flow,pressure equations are induced by the continuity equation.  The iteration method is used to 
simulate such pressure equations.  There are two types of iteration methods as shown above: the Jacobi and SOR (Successive Over-
Relaxation) methods.  The Jacobi method generally requires more time till the convergence (the residual of the entire equation falls 
below the convergence criterion set by the user) than the SOR method.  However, this method is useful in predicting the flow of melt 
that is symmetrical.  On the other hand, the SOR method does not guarantee symmetry of results but has a faster convergence 
speed than the Jacobi method.  
  
Maximum Iteration 
If convergence does not occur while carrying out iteration on pressure equations, the simulation can go on to infinity.  Thus, in such a 
case, terminate the iteration when it reaches the maximum iteration number and go onto the next time level.  If the value is too small
(<50), the errors that have not been converged pile up with the progress of the simulation.  This possibly brings down the accuracy of 
the simulation.  If the value is too big(>150), the iteration number increases too much and the overall simulation time takes too long.  
The value recommended in this program is 80~120. 
  
Ratio for Time Step 
Control the time step using the weighting value which is used for VOF equations.  If the front of the melt moves more than one grid, 
then it becomes difficult to accurately predict the free surface.  This can also result in the equations not converging. The value 
recommended in this program is 0.5~0.9. 
  

  Hybrid (0<Convection Scheme<1)  

Ratio for Time Step    Time control factor that calculates the progress of free surface 
    ( 0 < Weight for Time Step < 0.9, default value = 0.9 ) 
Treat the Solidified Volume as Obstacle   In flow analysis, solidified volume is treated as an 
obstacle. 

Solution Target    Indicate target to be simulated 

Solver Type    Select solver type  Explicit,Fully Implicit,Hybrid (0<Value<1, default 
value=0.5) 

Iteration Target    Variable that is solved by iteration method 
Iteration Method    Select from iteration. Jacobi (default value), SOR 
Relaxation Factor    Relaxation factor to be used during iteration simulation 

  SOR (1<Relaxation Factor<2), default value=1.6 

Convergence Criterion    Convergence criterion of iteration method( < 0.01, default value = 0.01) 
Maximum Iteration    Maximum number of iterations ( > 50, default value=100 ) 
Weighting for Time Step    Weighting for solver acceleration( default value = 30 ) 
Limit Time Step    Limit maximum time step 



Weighting for Time Step 
Usually the time step is set up by stability condition for simulation. The heat solver of anySOLVER can use more than the stable time 
step. This value is ratio to the stable time step 
Simulation End and Result Output Conditions 
  
  
This is where the simulation end time and result storage conditions are set.   
End Condition 
This is where the conditions to end the simulation are set.  The conditions are Filling Rate, Solidification Rate, Time, and Max. 
Temperature.  Select only one from these.   

   
    
Output Condition 
This is where the storage conditions of the simulation result files are set when anySOLVER is launched.   

           

Filling Rate    Simulation ends when filling rate exceeds the input value 
Solidification Fraction    Simulation ends when solidification fraction exceeds the input value 
Time    Simulation ends when simulation time exceeds the input value 

Max. Temperature  
    

Simulation ends when maximum temperature of the entire domain falls 
below the input value 

Type    Select a criterion variable for result storage(Filling Rate, Solidification Rate, 
Time) 

Data Start Initial storage point 
Data End    Final storage point 
Data Interval    Storage interval 
 
Add/Delete/Edit Data Interval 
Move to mouse to output list field and Click on the right mouse button to load the fast 
menu. In the fast menu, select Add/Edit/Delete/Delete or click on the below buttons. 



  
  

Note When anySOLVER saves result files in the data intervals designated in the Output Conditions, middle files(*.mid) are 
automatically created 

Launching anySOLVER 

  

Click on Run in Launching Conditions and the following anySOLVER window will load. 

  

 

  

Click on the activated Start button and the simulation will start. 

  

  

Note Refer to the anySOLVER manual for specifics on the program. 

    
Add data interval 
Possible to add one or more 

    Delete data interval 

    Edit data interval 



Setting Preferences 
  
This is where you preferences including unit, user database, background color, etc. are set.   

            
  
  
  

Unit      
Unit System    Select one from MKS, CGS, BTU 
Measurement Unit    Select measurement unit (inch, mm) 
Importer Unit    Set unit of STL file (inch, mm) 
Database      
User Database    Click   button and select user database file 
Default Material Spec.   

Select default  material specification displayed when database materials are 
shown 

Background      
Color    Select background color 
Gradient Background   Turn on/off background gradient 
Misc.      
Show  Report  After  Building 
Mesh    Show report after building mesh 
Max User View Point Number    Set maximum number of user view points  


